System Requirements

In order to use Altap Salamander, you will need Microsoft Windows 2000, Window XP, Windows Vista, Windows 7, or later.